Hirdetés

WordPress alapú weboldalad van? Akkor esélyesen az is nagy veszélyben forog!

|

Egy könnyen kihasználható sebezhetőséget találtak a File Manager bővítményben, melynek következtében honlapok tömkelegét érte támadás - és több millióban ketyeg az időzített bomba.

Hirdetés

A WordPress az egyik legnépszerűbb olyan keretrendszer, amellyel akár komolyabb programozói tudás nélkül is létrehozhatunk weboldalakat, még olyan bonyolultakat is, amelyekben blogtól a webáruházig sok mindenféle működik. A motort és a bővítményeket persze folyamatosan frissítik, egyrészt funkcióik bővítése miatt, másrészt pedig azért, mert a sok WP-alapú weboldal miatt gyakran is támadják ezeket, keresve a legkisebb sérülékenységeket. A Wordfence nevű webes tűzfal mögött álló cég, a Defiant jelezte először a legújabb problémát, melyet az okoz, hogy támadók képesek feltérképezni és kihasználni azokat a WordPress oldalakat, melyek a File Manager régebbi verzióját használják. A zero-day névre keresztelt sebezhetőség megengedte a rosszindulatú behatolóknak, hogy a WordPres bővítményén keresztül töltsenek fel kártevőket a honlapokra.

Hirdetés

Egyelőre nem tisztázott, hogy a hackerek hogyan szereztek tudomást a zero-dayről, de a Defiant szerint a múlt hét elején elkezdték feltérképezni azokat a weboldalakat, melyek a File Manager régebbi verzióját használják. Amint ilyenre bukkantak, kihasználták a zero-day sebezhetőségét és feltöltöttek egy képfájlnak álcázott kártevőt, mellyel utána képesek voltak átvenni az irányítást az oldal fölött.

A Defiant elmondta, hogy szeptember elseje óta 1,7 millió ilyen jellegű támadást akadályoztak meg, ami azt jelenti, hogy például a Webfence tűzfal felhasználóinak felénél jelen volt a probléma. A cég szakértője azt is elmondta, hogy feltételezéseik szerint sokkal több támadás történhetett ez idő alatt, mint amennyiről tudomásuk van.

A File Managert fejlesztő csapat még a probléma bejelentésének napján kiadott egy frissítést, mely kijavítja a hibát, azonban érthető módon ez lassan ér el minden honlap tulajdonoshoz, hiszen nem mindenki használja a WordPress nemrég bemutatott új funkcióját, mely automatikusan telepíti a legújabb frissítéseket. Ha tehát valaki WordPress alapú honlapot használ, jó ha megbizonyosodik róla, hogy azon telepítve van-e a File Manager bővítmény, ha pedig igen, akkor azonnal érdemes letölteni a legújabb frissítést.

Hirdetés
Ügyfélszolgálati változás!
0 mp. múlva automatikusan bezár Tovább az oldalra »

Úgy tűnik, AdBlockert használsz, amivel megakadályozod a reklámok megjelenítését. Amennyiben szeretnéd támogatni a munkánkat, kérjük add hozzá az oldalt a kivételek listájához, vagy támogass minket közvetlenül! További információért kattints!

Engedélyezi, hogy a https://computerworld.hu értesítéseket küldjön Önnek a kiemelt hírekről? Az értesítések bármikor kikapcsolhatók a böngésző beállításaiban.